当前位置:Gxlcms > 数据库问题 > 【UVa 1592】Database

【UVa 1592】Database

时间:2021-07-01 10:21:17 帮助过:1人阅读

If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter‘s Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

 

How to compete in ACM ICPC Peter peter@neerc.ifmo.ru
How to win ACM ICPC Michael michael@neerc.ifmo.ru
Notes from ACM ICPC champion Michael michael@neerc.ifmo.ru

The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.

技术分享技术分享

Given a table your task is to figure out whether it is in PNF or not.

 

Input 

Input contains several datasets. The first line of each dataset contains two integer numbers n and m ( 1技术分享n技术分享10000, 1技术分享m技术分享10), the number of rows and columns in the table. The following n lines contain table rows. Each row has m column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).

 

Output 

For each dataset, if the table is in PNF write to the output file a single word ``YES" (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``NO" (without quotes). On the second line write two integer row numbers r1 and r2 ( 1技术分享r1r2技术分享nr1技术分享r2), on the third line write two integer column numbers c1 and c2 ( 1技术分享c1c2技术分享mc1技术分享c2), so that values in columns c1 and c2are the same in rows r1 and r2.

 

Sample Input 

 

3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru

 

Sample Output 

 

NO
2 3
2 3
YES

首先有几个问题要注意一下。
fgets是读到回车并停止的,所以前面不能有回车。
要给每一个字符串分配一个编号。
接下来就是枚举+MAP判重了。

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<algorithm>
using namespace std;

struct hash
{
    int a[2];
    
    bool operator < (const hash &b) const
    {
        return a[0] < b.a[0] || (a[0] == b.a[0] && a[1] < b.a[1]);
    }
    
    bool operator == (const hash &b) const
    {
        return a[0] == b.a[0] && a[1] == b.a[1];
    }
};
int r;
int c;
map<string, int> idcard;
map<hash, int> app;
int table[10005][15];
int note;

void print()
{
    for (int i = 0; i < c; ++i)
        for (int j = i + 1; j < c; ++j)
        {
            app.clear();
            for (int k = 0; k < r; ++k)
            {
                hash dou;
                dou.a[0] = table[k][i];
                dou.a[1] = table[k][j];
                if (app.count(dou))
                {
                    printf("NO\n");
                    printf("%d %d\n", app[dou] + 1, k + 1);
                    printf("%d %d\n", i + 1, j + 1);
                    return;
                    
                }
                else
                {
                    app[dou] = k;
                }
            }
        }
    printf("YES\n");
}

int ID(string x)
{
    if (idcard.count(x)) return idcard[x];
    return idcard[x] = note++;
}

int main()
{
    while (scanf("%d %d", &r, &c) == 2)
    {
        char s[100];
        idcard.clear();
        note = 0;
        getchar();
        for (int i = 0; i < r; ++i)
        {
            fgets(s, 85, stdin);
            int k = 0;
            int len = strlen(s);
            string word = "";
            for (int j = 0; j < c; ++j)
            {
                while (k < len - 1 && s[k] != ,)
                    word += s[k++];
                table[i][j] = ID(word);
                word = "";
                ++k;
            }
        }
        print();
    }
    return 0;
}

 

【UVa 1592】Database

标签:

人气教程排行